/ / Polymer 1.0 não funciona - polímero, caramanchão, polímero-1.0

Polímero 1.0 não funciona - polímero, pavilhão, polímero-1.0

Eu estou tentando fazer um simples "Olá, mundo!"element. Tentei instalar os componentes do polímero com o bower e usei o arquivo zip. Também utilizei o servidor HTTP python e npm, mas ainda não obtive nenhuma saída. <html> <head> <title>Polymer</title> <script src="bower_components/webcomponentsjs/webcomponents-lite.min.js"></script> <link rel="import" href="elements/hello-world.html"> </head> <body unresolved> <hello-world></hello-world> </body> </html>

com o arquivo de elemento <link rel="import" href="../bower_components/polymer/polymer-mini.html"> <polymer-element name="hello-world" noscript> <template> <h1>Hello World!</h1> </template> </polymer-element>

Respostas:

7 para resposta № 1

Você está usando a API incorreta para o elemento polímero. Você deveria estar usando o <dom-module> como Trevor Dixon mencionou.

Veja Plunker

<link rel="import" href="../bower_components/polymer/polymer-mini.html">

<dom-module id="hello-world">
<template>
<h1>Hello World!</h1>
</template>
</dom-module>

<script>
Polymer({
is: "hello-world"
})
</script>

Perguntas relacionadas


Comentários (0)

Adicione um comentário