/ / Polymer 1.0 funktioniert nicht - Polymer, Laube, Polymer-1.0

Polymer 1.0 funktioniert nicht - Polymer, Laube, Polymer-1.0

Ich versuche, eine einfache "Hallo Welt!"Element. Ich habe versucht, die Polymer-Komponenten mit Bower installieren, und ich habe die Zip-Datei verwendet. Ich habe auch Python und Npm HTTP-Server, aber immer noch bekomme ich keine Ausgabe. <html> <head> <title>Polymer</title> <script src="bower_components/webcomponentsjs/webcomponents-lite.min.js"></script> <link rel="import" href="elements/hello-world.html"> </head> <body unresolved> <hello-world></hello-world> </body> </html>

mit der Elementdatei <link rel="import" href="../bower_components/polymer/polymer-mini.html"> <polymer-element name="hello-world" noscript> <template> <h1>Hello World!</h1> </template> </polymer-element>

Antworten:

7 für die Antwort № 1

Sie verwenden die falsche API für das Polymerelement. Du solltest das benutzen <dom-module> wie Trevor Dixon erwähnt.

Siehe Plunker

<link rel="import" href="../bower_components/polymer/polymer-mini.html">

<dom-module id="hello-world">
<template>
<h1>Hello World!</h1>
</template>
</dom-module>

<script>
Polymer({
is: "hello-world"
})
</script>

Verwandte Fragen


Kommentare (0)

Einen Kommentar hinzufügen