/ / Upgrade von Polymer 0,5 auf 0,8 - Javascript, Ruby-on-Rails-4, Polymer, Laube

Upgrade von Polymer 0.5 auf 0.8 - Javascript, Ruby-on-Rails-4, Polymer, Laube

Hallo Ich versuche, PolymerJs von zu aktualisieren 0.5 to 0.8 mit der Laube. Wie wir wissen, dass Laufen bower update aktualisiert alle notwendigen Pakete.

Aber leider aktualisiert es sich auf 0.5.5 nicht zu 0.8. Kann mir jemand bitte mitteilen, was genau das Problem ist oder wie kann ich das Upgrade erreichen? Sehr geschätzt. Vielen Dank

Antworten:

1 für die Antwort № 1

Ihre bower.json Datei sollte referenzieren Polymer/polymer#^0.8.0-rc.2. Höchstwahrscheinlich verweist es auf Version 0.5.x.

Es sollte jedoch angemerkt werden, dass viele der Standardkomponenten noch nicht mit 0.8 kompatibel sind, und viele Dinge können dadurch brechen.


1 für die Antwort № 2

Bitte beachten Sie, dass einige Elemente nicht auf 0.8 portiert wurden und nicht abwärtskompatibel sind. Sie können hier den Fortschritt der portierten Elemente überprüfen http://chuckh.github.io/road-to-polymer/repos-compare.html?load=true

Für Start neues Projekt mit Polymer können Sie es mit Bower wie unten tun

bower install --save Polymer/polymer#0.8-preview

Verwandte Fragen


Kommentare (0)

Einen Kommentar hinzufügen