/ / Polymer 1.0 virker ikke - polymer, bower, polymer-1.0

Polymer 1,0 virker ikke - polymer, bower, polymer-1.0

Jeg forsøger at lave en simpel "Hello World!element. Jeg har forsøgt at installere polymerkomponenterne med bower, og jeg har brugt zip-filen. Jeg har også brug for python og npm HTTP-server, men stadig får jeg ikke nogen output. <html> <head> <title>Polymer</title> <script src="bower_components/webcomponentsjs/webcomponents-lite.min.js"></script> <link rel="import" href="elements/hello-world.html"> </head> <body unresolved> <hello-world></hello-world> </body> </html>

med elementfilen <link rel="import" href="../bower_components/polymer/polymer-mini.html"> <polymer-element name="hello-world" noscript> <template> <h1>Hello World!</h1> </template> </polymer-element>

svar:

7 for svar № 1

Du bruger den forkerte API til polymerelementet. Du skal bruge <dom-module> som Trevor Dixon nævnte.

Se Plunker

<link rel="import" href="../bower_components/polymer/polymer-mini.html">

<dom-module id="hello-world">
<template>
<h1>Hello World!</h1>
</template>
</dom-module>

<script>
Polymer({
is: "hello-world"
})
</script>

Beslægtede spørgsmål


Kommentarer (0)

Tilføj en kommentar